Arsip Tag: error

OpenLiteSpeed Web Server – PHP Error Setelah Upgrade

Baru saja melakukan apt-get update && apt-get upgrade && apt-get dist-upgrade, muncul error saat akses ke website. Tidak begitu memperhatikan errornya, yang jelas errornya tentang missing module.

Setelah menelusuri, ternyata setelah upgrade, web server OpenLiteSpeed memanggil PHP processor bawaan. Sedangkan saya menggunakan LSPHP versi 5.6.

Solusinya, buatkan link ke direktori LSPHP 5.6 agar OpenLiteSpeed memanggil PHP processor yang benar saat mengeksekusi script PHP:

sudo ln -sf /usr/local/lsws/lsphp56/bin/lsphp /usr/local/lsws/fcgi-bin/lsphp5

Sekian.